User Management API Down
Incident Report for 75F
Postmortem

The User Management API is currently undergoing an infrastructure migration to convert all hosted resources to containerized instances. This migration has not yet been carried out on our production servers. There was a change recently introduced which had a dependency on the containerized deployment to execute automated database migrations. Since the production resources were not yet converted to run the service as a container, these database migrations never took place, causing wide-spread API failures after the deployment was carried out.

Simply rolling back this deployment and executing the database migrations manually resolved the issue

Posted Aug 29, 2023 - 12:59 CDT

Resolved
The User Management API (Caretaker) went unresponsive shortly after a routine application deployment. This is preventing users from using production apps and portals.
Posted Aug 29, 2023 - 12:15 CDT