[File Storage Service] [Degraded] Unexpected Outage

Incident Report for 75F

Resolved

The Azure-related disruption affecting the PROD storage account has been fully resolved. The service is now operating at 100% capacity with optimal performance.

We continue to monitor the platform to ensure sustained stability.
Posted Jun 27, 2025 - 06:50 CDT

Monitoring

The PROD storage account experienced degraded "GetBlob" performance (8–13% success rate vs. expected ~95%) due to an Azure platform-side anomaly.

Azure Support resolved the underlying cause, and service functionality has been restored. We are monitoring to ensure sustained stability.
Posted Jun 27, 2025 - 01:20 CDT

Update

We are continuing to investigate this issue. The Service is restored, partially.
Posted Jun 26, 2025 - 05:21 CDT

Update

The service continues to show fluctuations in the response time.
Posted Jun 26, 2025 - 01:40 CDT

Update

Partial Recovery. The Azure Blob Storage is responding better.
Posted Jun 26, 2025 - 01:15 CDT

Update

Azure Cloud Storage is responding super slow for file downloads.
Posted Jun 26, 2025 - 00:12 CDT

Investigating

File Storage service is degraded. No floor plans are getting fetched.
Under investigation.
Posted Jun 25, 2025 - 23:42 CDT
This incident affected: Portfolio Analytics.