Haystack API Down
Incident Report for 75F
Resolved
Database operations have completely stabilized and platform health has been consistent. Availability of the Apps and Portals, and cloud communication for CCUs have been restored
Posted Sep 06, 2023 - 09:10 CDT
Monitoring
Platform response times have remained steady and we will continue to focus efforts on pinpointing the root cause of the DB load surge and subsequent service degradation.
Posted Sep 06, 2023 - 08:47 CDT
Update
The database upgrade is complete and we are beginning to see improvements in platform response times.
Posted Sep 06, 2023 - 08:40 CDT
Update
The cloud database upgrade is still in progress. The deployment is complete in 1 of the 3 servers in our cluster. Haystack API availability is still degraded.
Posted Sep 06, 2023 - 08:30 CDT
Update
We are in the process of upgrading our cloud database cluster to handle this load surge. The deployment may take several minutes to complete. But once complete, it will restore availability of the Haystack API and allow us focus efforts on pinpointing and addressing the cause
Posted Sep 06, 2023 - 08:20 CDT
Update
A surge of read requests is compounding and impacting the performance and availability of our Cloud Database. As a result, the availability of the Haystack API is degraded. We are still working to pinpoint and address the source of this added load
Posted Sep 06, 2023 - 08:14 CDT
Investigating
We are currently investigating this issue.
Posted Sep 06, 2023 - 08:12 CDT
This incident affected: Haystack API.